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This lab aims to help you begin to understand the nature and statistical properties of digital 

remote sensing images.  For this purpose ENVI tutorial files are used. By the end of the lab 

you should have a working knowledge of basic image operations in ENVI and have a basic 

understanding of digital images.  

 

 

ENVI Main Menu Bar 

In ENVI, activities are initiated by using the menus in the ENVI main menu bar, which may be 

oriented horizontally as shown below, or vertically (as set via the option on the File > 

Preferences >Miscellaneous tab). 

 

 

Opening an image file using ENVI 4.8. 

 From the ENVI main menu bar, select File > Open Image File.  

 Navigate to the  given “can_tm” directory, select the file “can_tmr” from the list, and 

click Open. This is Canon City, Colorado. U.S.A.. 



 

 

 

The Available Bands List dialog appears on your screen. This list allows you to select 

spectral bands for display and processing. You have the choice of loading either a grayscale 

or an RGB color image. 

 

 Select TM Band 4. The band you have chosen is displayed in the field marked 

Selected Band. 

 

 Click the Gray Scale radio button then click Load Band to load the image into a new 

display. Band 4 will be loaded as a gray scale image. 

 

Canon City, Colorado 



 

 
 
When the image loads, an ENVI image display appears on your screen. The display group 

consists of an Image window, a Scroll window, and a Zoom window. These three windows 

are intimately linked; changes to one window are mirrored in the others. You can choose 

which combinations of windows appear on the screen by right-clicking on any display group 

window to display the right-click menu and selecting a style from the Display Window Style 

submenu. Use the ENVI main menu bar File > Preferences > Display Defaults tab to 

change the default settings for which windows you wish to display and where you wish to 

position them. All windows can be resized by grabbing and dragging a window corner with 

the left mouse button. 

1. Resize the Image window to be as large as possible (until the Scroll window disappears). 

2. Now, make the Image window smaller than the full extent of the image data (the Scroll 

window will reappear). 

3. Resize the Zoom window and notice how the outlining box changes in the Image window. 

 

 

 



 

 

 

Right-click menus. 

Each of the three display windows has a right-click menu for accessing general display 

settings and some interactive functions. Access this menu by right-clicking in the window. 

 



 

 
 
 

Applying Z- profile (spectrum) 

 Place the cursor anywhere in the Image window and click the right mouse button. Click the 

left mouse button to Z profile (Spectrum). A spectral profile now appears depicting all the 

values you can get for each channel of the image. When you place the cursor on another 

pixel in the image window spectral profile changes accordingly. You can modify the 

appearing plot diagram by clicking Edit and then Plot Parameters. If you press Data Values 

you can see the data corresponding to each pixel for each channel.  

 

 
 



 

 
 
 
 

The Image Window 

The Image window shows a portion of the image at full resolution. A small box at this image 

depicts the zoom box appearing separately.  

 

 

The Display Group Menu Bar 

The menu bar in the display group provides access to many ENVI features related to the 

images in the display group. This menu appears at the top of the Image window by default. If 

you have chosen to display only the Scroll and Zoom windows or just the Zoom window, the 

menu bar will appear at the top of the Zoom window. 



 

 
 
 

The Image Window Zoom Box 

The Zoom box (the colored box in the Image window) indicates the region that is displayed in 

the Zoom window. 

1. Place the mouse cursor in the Zoom box in the Image window, hold down the left mouse 

button, and move the mouse. The Zoom window is updated automatically when the mouse 

button is released. 

2. Place the cursor anywhere in the Image window (outside of the Zoom box) and click the 

left mouse button to move the magnified area instantly. If you click, hold, and drag the left 

mouse button in this fashion, the Zoom window is updated as you drag. 

3. Click once in the Zoom box in the Image window and use the arrow keys on your keyboard 

to move the box. To move several pixels at a time, hold down the Shift key while using the 

arrow keys. 

 

 

 

 



 

Scroll Bars 

You can choose to have scroll bars displayed in the Image window. These scroll bars provide 

a way to move through the Scroll window, allowing you to select which portion of the image 

appears in the Image window. 

1. Right-click in the Image window and select Toggle > Display Scroll Bars. 

2. To have scroll bars appear in the Image window by default, use the ENVI main menu bar 

to select the File > Preferences > Display Defaults tab. Set the Image Window Scroll 

Bars toggle to Yes. 

 
 

The Zoom Window 

The Zoom window shows a portion of the image magnified the number of times indicated by 

the number shown in parentheses in the Title Bar of the window. The zoom area is indicated 

by a highlighted box (the Zoom box) in the Image window. 

 
There are three Zoom controls (red by default) in the lower left corner of the Zoom window. 

These control the zoom factor and the crosshair cursor in both the Zoom and Image 

windows. 

1. Place the mouse cursor in the Zoom window and click the left mouse button to reposition 

the magnified area (displayed in the Zoom box in the Image window) by centering the 

zoomed area on the selected pixel. 

2. Click and hold the left mouse button in the Zoom window while dragging. This causes the 

Zoom window to pan within the Image window. 

3. Click the left mouse button on the graphic in the lower left corner of the Zoom window to 

zoom out by a factor of 1. 

4. Using a three button mouse, click the middle mouse button on the graphic to zoom out by 

a factor of 2. 

5. Click the right mouse button on the graphic to return the Zoom window to the default zoom 

factor. 

6. Click the left mouse button on the graphic to zoom in by a factor of 1. 

7. Click the middle mouse button on the graphic to zoom in by a factor of 2. 

8. Click the right mouse button on the graphic to return the Zoom window to the default zoom 

factor. 

9. Click the right  mouse button on the graphic to toggle the crosshair cursor in the Zoom 

window on or off. 

10. Click the middle mouse button on the graphic to toggle the crosshair cursor in the Image 



 

window on or off. 

11. Click the right mouse button on the graphic to toggle the Zoom box in the Image window 

on or off. 

12. The Zoom window can also have optional scroll bars, which provide an alternate method 

for moving through the Zoom window. Right-click in the Zoom window and select Toggle > 

Zoom Scroll Bars. To have scroll bars appear on the Zoom window by default, use the 

ENVI mainmenu bar to select the File > Preferences > Display Defaults tab. Set the Zoom 

window Scroll Bars toggle to Yes. 

 

 

 

The Scroll Window  

 

The Scroll window displays the entire image at reduced resolution (subsampled). The 

subsampling factor is listed in parentheses in the window Title Bar at the top of the image. 

The highlighted Image box (red by default) indicates the area shown at full resolution in the 

Image window. 

 

1. Place the mouse cursor inside the Image box, hold down the left mouse button, drag to the 

desired location, and release to reposition the portion of the image shown in the Image 

window. The Image window is updated automatically when the mouse button is released. 

2. Click anywhere within the Scroll window using the left mouse button to instantly move the 

selected Image window area. If you click, hold, and drag the left mouse button in this fashion, 

the Image window will be updated as you drag (the speed depends on your computer 

resources). 

3. Click in the Image box and press the arrow keys on your keyboard. To move the image in 

larger increments, hold down the Shift key while using the arrow keys. 

Zoom level 

Zoom controls 



 

 

 

 

 

 
 

 

 

 

Applying a Contrast Stretch 

By default, ENVI displays images with a 2% linear contrast stretch. You can choose to apply 

a different contrast stretch. 

1. From the Display group menu bar, select Enhance to display a list of six default stretching 

options for each of the windows in the display group (Image, Zoom, Scroll). 

2. Select an item from the list (for example, Enhance > [Image] Equalization to apply a 

histogram equalization contrast stretch to the Image window). This action also updates the 

Scroll and Zoom windows in the display group. Try applying several of the different available 

stretches. 

3. Alternatively, you can define your contrast stretch interactively by selecting Enhance > 

Interactive Stretching from the Display group menu bar. 

 

Applying a Color Map 

By default, ENVI displays images using a grayscale color table. You can apply a pre-defined 

color table to an image or select a color table from a list. 

1. From the Display group menu bar, select Tools > Color Mapping > ENVI Color Tables to 

display the ENVI Color Tables dialog. 

2. Select a color table from the list at the bottom of the dialog to change the color mapping 

for the three windows in the display group. 

3. In the ENVI Color Tables dialog, Auto Apply is selected by default (Options > Auto 

Apply), so the color table will automatically be applied. You can toggle this feature on or off 

using this menu option. If Auto Apply is off, you must select Options > Apply each time you 

wish to apply the color table and observe the results. 

Subsampling 

factor 

Image box 



 

4. From the ENVI Color Tables menu bar, select Options > Reset Color Table to return the 

display group to the default grayscale color mapping. 

5. From the ENVI Color Tables menu bar, select File > Cancel to dismiss the dialog. 

 
 

 
 
 
 

Animating Your Image 

You can animate a multiband image by cycling through the bands of the image sequentially. 

1. From the Display group menu bar, select Tools > Animation then click the OK button on 

the Animation Input Parameters dialog. Each of the six bands from the TM scene is loaded 

into an Animation window. Once all the bands are loaded, the images are displayed 

sequentially creating a movie effect. You can control the animation using the player control 

buttons (loop backward, loop forward, change direction, and pause) at the bottom of the 

Animation window, or by adjusting the value shown in the Speed spin box to change the 

speed at which the bands are displayed. 

2. From the Animation menu bar, select File > Cancel to end the animation. 

 

 

 

 



 

Using Scatter Plots and Regions of Interest 

Scatter plots allow you to quickly compare the values in two spectral bands simultaneously. 

ENVI scatter plots enable a quick 2-band classification. 

1. From the Display group menu bar, select Tools > 2D Scatter Plots to display the 

distribution of pixel values between Band 1 and Band 4 of the image as a scatter plot. The 

Scatter Plot Band Choice dialog appears. 

2. Under Choose Band X, select Band 1. Under Choose Band Y, select Band 4. Click OK 

to create the scatter plot. 

3. Place the cursor in the Image window (but not inside the Zoom box), then click and drag 

using the left mouse button to move the cursor around in the window. As you move the 

cursor, you will notice different pixels are highlighted in the scatter plot, making the pixels 

appear to “dance.” The dancing pixels in the display are the highlighted 2-band pixel values 

found in a 10-pixel by 10-pixel region centered on the cursor. 

4. Define a region of interest (ROI) in the Scatter Plot window. To do this, click the left mouse 

button several times in different areas in the Scatter Plot window. Doing this selects points to 

be the vertices of a polygon. Click the right mouse button when you are done selecting 

vertices. This closes the polygon. Pixels in the Image and Zoom windows whose values 

match the values contained in the selected region of the scatter plot are highlighted. 

5. To define a second ROI, left-click a few times in the scatter plot to define the vertices of 

the next ROI class, and right-click to close the new polygon. 

6. From the Scatter Plot menu bar, select Class > New and repeat the actions described in 

the step 4. 

7. From the Scatter Plot menu bar, select Class > Items 1:20, choose the color for your next 

ROI, and repeat the actions described in step 4. 

8. From the Scatter Plot menu bar, select Options > Export All to export the regions of 

interest. The ROI Tool dialog appears. The ROI Tool dialog can also be started from the 

menu bar in the Image window by selecting Overlay > Region of Interest. 

9. From the ROI Tool menu bar, select File > Cancel to dismiss the dialog. The region 

definition is saved in memory for the duration of the ENVI session. 

10. From the Scatter Plot menu bar, select File > Cancel to close the Scatter Plot window. 

 

 

Loading an RGB Image 

ENVI allows you to simultaneously display multiple grayscale and/or RGB color composite 

images. 



 

1. Click on the Available Bands List. If you dismissed the Available Bands List during the 

previous exercises, you can recall it from the ENVI main menu bar by selecting Window > 

Available Bands List. 

2. Click on the RGB Color radio button in the Available Bands List. Red, Green, and Blue 

fields appear in the middle of the dialog. 

3. Select Band 7, Band 4, and Band 1 sequentially from the list of bands at the top of the 

dialog by left-clicking on the band names. The band names are automatically entered in the 

Red, Green, and Blue fields. 

4. Click the Display #1 button at the bottom of the Available Bands List and select New 

Display. 

5. Click Load RGB to load the image into ENVI. 

 

 

Classifying an Image 

ENVI provides two types of unsupervised classification and several types of supervised 

classification. 

The following example demonstrates one of the supervised classification methods. 

1. From the ENVI main menu bar, select Classification > Supervised > Parallelepiped. 

2. In the Classification Input File dialog, select can_tmr.img, and click OK. The Parallelepiped 

Parameters dialog appears. 

3. Select the regions of interest (ROIs) you created previously by clicking on the region name 

in the Select Classes from Regions list at the left of the dialog. 

4. Select Memory in the upper right corner of the dialog to output the result to memory. 

5. Set the Output Rule Images toggle to No, then click OK. The classification function 

calculates statistics, and a progress window appears during the classification. A new entry 

called Parallel (CAN_TMR.IMG) is added to the Available Bands List. 

6. In the Available Bands List, click Display #1 and select New Display. 

7. In the Available Bands List, select the Gray Scale radio button, click on Parallel (CAN_ 

TMR.IMG), and select Load Band. A new display group containing the classified image is 

loaded. 

 



 

 

 

 

Dynamically Overlaying Images 

You can link two display groups, allowing direct comparison of the images by displaying one 

on top of the other. 

1. From either of the two Display group menu bars, select Tools > Link > Link Displays. 

The Link Displays dialog appears. Click OK to link at the origin. 

2. In either of the two Image windows, position the cursor outside the Zoom box and click 

and hold the left mouse button. A portion of the second image is superimposed over the first 

image. 

3. Change the size of the superimposed area by clicking and dragging the middle mouse 

button until the superimposed area is the desired size, then click and hold the left mouse 

button again. 

4. Close the two display groups by selecting File > Cancel from each of the Display group 

menu bars. 

 

Overlaying and Working with Vectors 

ENVI provides a full suite of vector viewing and analysis tools, including input of ArcView 

shapefiles, vector editing, and vector querying. 

1. Click on TM Band 4 in the Available Bands List, click the Gray Scale radio button, then 

click Load Band to re-display the grayscale image. 



 

2. From the ENVI main menu bar, select File > Open Vector File to open a vector file. 

3. In the Select Vector Filenames dialog, navigate to the can_tm directory, click can_v1.evf, 

hold the Shift key down and click the last file (can_v4.evf) from the list (all four .evf files 

should be selected), then click Open. The Available Vectors List dialog appears listing the 

vectors corresponding to the can_tmr.img display. 

4. Click on one of the vector layer names and examine the information about the layer at the 

bottom of the Available Vectors List. 

5. Click the Select All Layers button near the bottom of the dialog to select all of the listed 

vectors to plot, then click the Load Selected button. 

6. When the Load Vector Layer dialog appears, click Display #1 to load the vectors into the 

first display. The vector layers are listed in the #1 Vector Parameters dialog. 

7. In the Display #1 Vector Parameters dialog, click Apply to load the vectors onto the 

image. From the Vectors Parameters menu bar, select Options > Vector Information to 

start an information dialog about the vectors. 

8. To display the currently selected vector layer and list basic information about the vectors, 

click and drag using the left mouse button in the Image window. 

9. Click on another layer name in the Vector Parameters dialog then click and drag in the 

Image window to track a different layer. 

10. From the Vector Parameters menu bar, select Edit > Edit Layer Properties. Change 

vector layer parameters as desired and click OK. 

11. In the Vector Parameters dialog, click Apply to display the changes. 

12. You can finish your ENVI session from the ENVI main menu bar File > Exit option. 

Answer Yes to the "Terminate this ENVI Session?" prompt. All files are closed automatically. 

 

 

 

 


