
 
 

 

 

ENVI 5.0: TUTORIAL 3 

 
------------------------------------------------------------------------------------------------- 

 
 

In this exercise, you can learn how to make unsupervised and supervised classification using 

ENVI 5.0. Generally, classification is the process of assigning class membership to a set of 

samples. In the case of remote sensing, the samples are the pixels of a specific image. Pixels 

can be classified on the basis of spectral similarity, using a variety of statistical techniques. 

Classes may be defined using ground reference data and/or previous knowledge of the site.  

This exercise leads you through a typical multispectral classification procedure using Landsat 

TM data for eastern Thessaly, central Greece. Results of both unsupervised and supervised 

classifications are examined and discussed. 

 

1. Locate the TM image that corresponds to 15/8/2011. Select the file and click Open 

Image File on the ENVI main menu. You can open the image directly as an external 

file (GeoTIFF with metadata).  

2. You may only use the bands 1,2,3,4,5 and 7. Calibrate the images. Go to “Basic 

Tools” Pre-processingCalibration utilitiesLandsat Calibration. 

 
 

3. Save the output and open as an RGB color (4,3,2 channels). Resize the image. You 

can avoid large files using only the desired geographical regions. From the Basic 

Tools menu click resize data (spatial). This menu also allows you to select specific 

spectral bands for display and processing. 



 

4. You have the choice of loading either a gray scale or an RGB color image. Select the 

RGB Color radio button in the Available Bands List, and then click on bands 4,3, and 

2 sequentially with the left mouse button. The bands you have chosen are now 

displayed in the appropriate fields in the center of the dialog. 

5. Use the displayed color image as a guide to classification. 

6. Review Image Colors there are areas that have similar spectral characteristics. 

Bright red areas on the image have high infrared reflectance and low reflectance in the 

red and green, which is characteristic of healthy vegetation, especially that under 

cultivation. Slightly darker red areas typically represent native vegetation. Water 

surfaces (Pagasitikos Golf and Lake Karla) are also readily apparent. Urbanization and 

clouds are also easy to detect. The following figure shows the resulting image file. 

 
 

 

Unsupervised classification 

 

Start exploring ENVI‘s unsupervised classification capabilities using the ENVI main menu, 

by choosing Classification → Unsupervised → K-Means or IsoData. 

 

K-Means 

 

Theory: Unsupervised classifications use statistical techniques to group n-dimensional data 

into their natural spectral classes. The K-Means unsupervised classifier uses a cluster 

analysis approach which requires the analyst to select the number of clusters to be located in 

the data. The classifier arbitrarily locates this number of cluster centers, and then iteratively 

repositions them until optimal spectral separability is achieved. 

 

1. Select Classification → Unsupervised → K-Means, and use all the default values. 



 

2. Select the previous saved image of your own and click OK. 

3. Select the number of the desired classes and click OK. 

4. Load the new image file just clicking on the Gray Scale Radio Button Load Band      

Keep the initial image on Available Band Lists Window, open it and Link it with the 

new   classification image file. Select Tools → Link → Link Displays and click OK in 

the dialog in order to link the images. 

5. Compare the classification result with the initial color composite image. 

6. Try to identify the land cover associated with each class 

7. Experiment with different numbers of classes 

 

 

 
 

 

IsoData 

 

Theory: IsoData unsupervised classification calculates class means evenly distributed in the 

data space and then iteratively clusters the remaining pixels using minimum distance 

techniques. Each iteration recalculates means and reclassifies pixels with respect to the new 

means. This process continues until the number of pixels in each class changes by less than 

the selected pixel change threshold or when the maximum number of iterations is reached. 

 

1. Select Classification → Unsupervised → IsoData, and use all the default values. 

2. Select the previous saved image of your own and click OK. 

3. Select the range number of the desired classes and click OK. 

4. Try to identify the land cover associated with each class and write this down. 



 

5. Load the new image file just by clicking on the Gray Scale Radio Button Load 

Band. Keep the initial image on Available Band Lists Window, open it and Link it 

with the new classification image file. Select Tools → Link → Link Displays and 

click OK in the dialog to link the images. Do exactly the same with the previous K-

Means classification image file.  

6. Compare the results of the two methods. It is very possible that the two classifiers may 

have assigned different colors to similar spectral classes. Try to find the reason for this 

difference. 

7. Experiment with different numbers of classes, change thresholds, standard deviations, 

maximum distance error, and class pixel characteristic values to determine their effect 

on the classification. 

8. You may close your K-Means and IsoData classification images. 

 

 

 
 

 

Supervised classification 

 

At the supervised classifications the user selects manually training areas in order to define 

each class. After the definition of each class, every pixel is then compared to the training data 

and assigned to the most appropriate class. There are many different supervised classification 

methods including Parallelepiped, Minimum Distance, Mahalanobis Distance, Maximum 

Likelihood, Spectral Angle Mapper, Binary Encoding, and Neural Nets.  

 

In order to perform your own classifications, from the ENVI main menu select Classification 

→ Supervised → [method], where [method] is one of the supervised classification methods 



 

found in the pull-down menu (Parallelepiped, Minimum Distance, Mahalanobis Distance, 

Maximum Likelihood, Spectral Angle Mapper, Binary Encoding, or Neural Net).  

 

For the selection of training areas Regions of Interests (ROIs) can be used. You can either use 

predefined ROIs, or create your own. 

 

 

Restore or create ROIs 

 

If there previous saved ROIs for the same region under consideration, and if the images are 

appropriately georeferenced, you can restore the  ROIs simply by opening the ROI Tool 

dialog by choosing Overlay → Region of Interest in the display image window.  In the ROI 

Tool dialog, choose File → Restore ROIs. 

 

You can also create your own new ROIs. Select Overlay → Region of Interest from the Main 

Image window menu bar. The ROI Tool dialog for the display group appears. In the Display 

Image window draw a polygon representing the new region of interest. To do this, click the 

left mouse button in order to establish the first point of the ROI polygon. Select further border 

points in sequence by clicking the left button again, and close the polygon by clicking the 

right mouse button. The middle mouse button deletes the most recent point, or (if you have 

closed the polygon) the entire polygon. Fix the polygon by clicking the right mouse button 

later on. When you have finished creating a ROI, its definition is shown in the table of the 

ROI Tool dialog. The definition includes the name, region color, number of pixels enclosed, 

as well as other ROI properties. 

 

 

Supervised Multispectral Classification Methodologies 

 

Parallelepiped 

 

A simple decision rule is used here in order to classify multispectral data. The decision 

boundaries form an n-dimensional parallelepiped in the image data space. The dimensions of 

the parallelepiped are defined based upon a standard deviation threshold from the mean of 

each selected class. Pixels are assigned to a class when they occur within that class‘s 

parallelepiped. In the case that they are outside of the parallelepipeds, they are left 

unclassified. 

 

In order to create a parallelepiped classification, go to the Main ENVI menu and select 

Classification → Supervised→ Parallelepiped. You can run the classification using the default 

parameters and the previous created ROIs. Save your results in the folder of your choice. 

Compare this classification with the color composite image. Do you see any pixels that are 

obviously misclassified? 

 



 

Minimum distance 

 

This type of classification uses the mean spectral values of each ROI and calculates the 

Euclidean distance from each unknown pixel to the centroid for each class. In this way, all 

pixels are classified to the closest ROI class unless the user specifies standard deviation or 

distance thresholds, in which case some pixels may be unclassified in the case that they do not 

meet the selected criteria. 

 

In order to create a minimum distance classification, go to the Main ENVI menu and select 

Classification → Supervised→ Minimum Distance. You can run the classification using the 

default parameters and the previous created ROIs. Save your results in the folder of your 

choice. Compare this classification with the color composite image. Do you see any pixels 

that are obviously misclassified? Can you observe any significant differences?  

 

 

Maximum Likelihood 

 

Maximum likelihood classification assumes that the reflectance values for each class in each 

band are normally distributed and calculates the probability that a given pixel belongs to each 

class. Unless a probability threshold is selected, all pixels are classified. Each pixel is 

assigned to the class for which it has the highest probability of membership (i.e., the 

maximum likelihood). 

 

In order to create a maximum likelihood classification, go to the Main ENVI menu and select 

Classification → Supervised→ Maximum Likelihood). You can run the classification using 

the default parameters and the previous created ROIs. Save your results in the folder of your 

choice. Compare this classification with the color composite image. Do you see any 

significant differences?  

 

 

 

 

Mahalanobis distance 

 

 

The Mahalanobis Distance classification is based on a direction sensitive distance classifier 

that uses covariance statistics in addition to class means and standard deviations. It is very 

similar to the Maximum Likelihood classification but assumes all class covariances are equal 

and therefore is a faster method. All pixels are classified to the closest ROI class unless the 

user specifies a distance threshold, in which case some pixels may be unclassified if they do 

not meet the threshold. 

 

In order to create a Mahalanobis distance classification, go to the Main ENVI menu and select 

Classification → Supervised→ Mahalanobis distance classification. You can run the 

classification using the default parameters and the previous created ROIs. Save your results in 

the folder of your choice. Compare this classification with the color composite image. Do you 

see any pixels that are obviously misclassified? Can you observe any significant differences 

between the parallelepiped and minimum distance results?  

 

 



 

Post-classification 

 

 

Combine Classes 

 

The Combine Classes function provides an alternative method for classification 

generalization. Similar classes can be combined into a single more generalized class. 

 

Perform your own combinations as described below: 

1. Select Classification→ Post Classification → Combine Classes. 

2. Select the previous classification and click OK. 

3. Choose the first (as the input class) to combine with Unclassified (as the output class), and 

click on Add Combination, and then OK in the Combine Classes Parameters dialog. 

Choose ―Yes in response to the question ―Remove Empty Classes? Output as 

a new image and click OK. 

4. Compare the combined class image to the classified images.  

 

 

Edit Class Colors 

 

When a classification image is displayed, you can change the color associated with a specific 

class by editing the class colors: 

 

1. Select Tools → Color Mapping → Class Color Mapping in the Main Image Display 

window of the classification image. 

2. Click on one of the class names in the Class Color Mapping dialog and change the color by 

dragging the appropriate color sliders or entering the desired data values. You may choose 

from a pulldown menu of color options by clicking on the ― Color menu. Changes are 

applied to the classified image immediately. To make the changes permanent, you can select 

Options → Save Changes in the dialog. You can also edit the names assigned to classes in this 

dialog. 

 

 

Classes to Vector Layers 

 

Execute the function and convert one of the classification images to vector layers which you 

can use in a GIS. 

 

1. Select Classification→ Post Classification → Classification to Vector and choose the 

Selected classification file within the Raster to Vector Input Band dialog.  

 

2. In the Raster to Vector Parameters, you can choose which classes you wish to convert to 

vectors and also whether you would like all classes to be in a single vector file or for a 

separate vector file to be created for each class. 

 

3. It is possible that the described conversion to vectors would be very time consuming, so be 

patient. 

 

 

 



 

Classification Keys Using Annotation 

 

ENVI provides annotation tools to put classification keys on images and in map layouts. The 

classification keys are automatically generated. 

 

1. Choose Overlay → Annotation from the Main Image window menu bar for one of the 

classified images. 

 

2. Select Object → Map Key to add a legend to the image. You can edit the key 

characteristics by clicking on the Edit Map Key Items button in the Annotation: Map Key 

dialog and changing the desired characteristics. You should shorten the class names that 

will be displayed. 

 

3. Click in the image display to place the key. In the Annotation dialog, turn on the 

background and choose a background color that will allow your legend to be legible. 

 

4. Click in the display with the right mouse button to finalize the position of the key. For 

more information about image annotation, please see previous exercises. 

 

 

 

 


