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 Structured ASIC
− HardCopy® II, HardCopy Stratix 

 High & Medium Density FPGAs
− Stratix II, Stratix, APEX™ II, APEX 

20K, & FLEX 10K®

 Low-Cost FPGAs
− Cyclone II & Cyclone

 FPGAs with Clock Data Recovery
− Stratix II GX 

 CPLDs
− MAX II, MAX 7000 & MAX 3000

 Embedded Processor Solutions
− Nios II

 Configuration Devices
− Serial (EPCS) & Enhanced (EPC)

Programmable Logic Families
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MAX 7000A & MAX 3000A Family 
Overview
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Complete Voltage Portfolio  

MAX 7000S MAX 7000AE

MAX 3000A

MAX 7000B
 Performance 

Leader
 Feature Leader
 Wide Range of 

Package Offerings
 Industrial-Grade 

Offerings

 High Performance
 Feature Leader
 Wide Range of 

Package Offerings

 Price Leader
 Feature & Package 

Subset of 
MAX 7000AE

 High Performance
 Feature Leader
 Wide Range of 

Package Offerings

5.0 V 2.5 V3.3 V



Copyright © 2005 Altera Corporation
5

MAX Device Block Diagram
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MAX Macrocell
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MAX II: The Lowest-Cost CPLD Ever

 New Logic Architecture
− 1/2 the Cost
− 1/10 the Power Consumption
− 2X the Performance
− 4X the Density

 Non-Volatile, Instant-On
 Supports 3.3-, 2.5- & 1.8-V 

Supply Voltages

Breakthrough Technology 
to Expand the Market

Presenter
Presentation Notes
The four key benefits are compared to MAX: ½ cost; 1/10 power; 2X performance; 4X density.
Non-volatility, instant-on, single-chip are “must have” characteristics of a CPLD.
Flexible supply voltage details – 3.3V & 2.5V are a single ordering code; 1.8V is a separate ordering code (separate mask set). 1.8V option will be same price, same performance, with lower power.
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Flexible Supply Voltage
On-Chip Voltage 

Regulator
Accepts 3.3-, 2.5- &

1.8-V Supply Inputs
 Internally Converted to 

1.8-V Core Voltage

Convenience of 3.3 V with
the Power & Performance of 1.8 V

Presenter
Presentation Notes
Two sets of ordering codes, e.g. EPM1270 (2.5V/3.3V) and EPM1270G (1.8V). Performance and price are the same. Power is much lower in the 1.8V version (2mA standby vs. 12mA standby) because it bypasses the regulator. 

3.3/2.5V version will be available first. 1.8V version will follow at a later time.

Did not make 1 single device with all 3 Vcc options because we wanted to have a low power device (1.8V). This bypasses the voltage regulator so it doesn’t draw the current associated with that regulator. 
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MAX II Device Family

Device
Logic 

Elements 
(LEs)

Typical
Macro-
cells

User 
I/O 

Pins

Speed
Grades

Fastest
tpd1
(ns)

User 
Flash 

Memory
(bits)

EPM240 240 192 80 3, 4, 5 4.7 8,192

EPM570 570 440 160 3, 4, 5 5.5 8,192

EPM1270 1,270 980 212 3, 4, 5 6.3 8,192

EPM2210 2,210 1,700 272 3, 4, 5 7.1 8,192

Presenter
Presentation Notes
Densities lower than 128 MCs addressed with current MAX device families. They still meet the fitting, performance and I/O requirements of current designs.
Typical macrocells are shown to give an approximate density for designers who are accustomed to thinking in macrocells. These are not absolute conversions, but are based on a 1.3 logic element to 1 macrocell ratio, based on a suite of benchmark designs. 
The speed grades are FPGA-like and do NOT represent absolute tpd. -3 is the fastest, -4 is medium and -5 is slowest. Each density has a different spec for each speed grade. 
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Device
100-Pin TQFP1

0.5-mm Pitch
16 x 16 mm

144-Pin TQFP
0.5-mm Pitch
22 x 22 mm

256-Pin FBGA2

1.0-mm Pitch
17 x 17 mm

324-Pin FBGA
1.0-mm Pitch
19 x 19 mm

EPM240 80

EPM570 76 116 160

EPM1270 116 212

EPM2210 204 272

Presenter
Presentation Notes
MAX II is offered in four low-cost packages. These are NOT pin-compatible with MAX CPLDs.

Each package was optimized for one specific density to have the max number of I/Os for that package. The EPM570 in the F256 was not the density optimized for that package, which is why it only has 160 I/O. 

As you increase in density in the same package, you lose I/O to extra GND and VCC pins. The exception is the EPM1270 in the T144 package, which has enough GND and VCC pins, so it doesn’t “lose” any from the EPM570 in the same package.
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New Small Packages

 Packages minimize PCB area and optimize 
ease-of-use
− Partial arrays allow for 2 layer PCB break out

T100
0.5mm TQFP

16x16mm

Partial 
M100

0.5mm MBGA
6x6mm

Partial
M256

0.5mm MBGA
11x11mm

F256
1.0mm FBGA

17x17mm
New Packages
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MAX II Architecture 

Staggered 
I/O Pads

User Flash
Memory

Logic 
Elements
(LEs)

JTAG & 
Control 
Circuitry

Configuration 
Flash Memory

Presenter
Presentation Notes
The MAX II floorplan consists of a staggered ring of I/O, which are optimized for small size & pad pitch. This “donut” ring of I/Os defines the actual die size. Inside the I/O ring, we used SRAM-based, logic elements (4-input LUT plus register) to achieve the highest logic efficiency at the lowest price points. The configuration flash memory block and user flash memory block are the non-volatile part of the device. The configuration flash memory loads the design into the SRAM core upon power up, and the user flash memory (8Kb) can be used to store user data. The user does not have access to the config flash memory block. The config flash memory block size ranges from 50-300Kb, depending on device density.

This depiction is a marketing diagram – the actual floorplan shape is shown in the datasheet & in the software.
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MAX II Logic Element (LE)
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Presenter
Presentation Notes
Identical to Cyclone devices
Enhanced register packing due to combination of LUT & register chain
Register can be used on LE input, not just output
Register feedback is useful when you want to register the input of a block in a block-based design
It saves you from having to consume an entire LE to implement an input register
The combination of the register chain and feedback reduces LE resource usage on average by about 20% versus APEX II
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User Flash Memory 
 Feature 

− Flash Memory 
Storage Bank

− 8,192 Bits Per Device
− Interface to SPI, I2C, 

Parallel, or Proprietary 
Buses

 Applications
− Store Revision & Serial 

Number Data
− Store Boot-Up & 

Configuration Data

Industry
First!

User Flash 
Memory Block

Presenter
Presentation Notes
Every device has the same number of user flash memory bits, 8192. 
Current program/erase spec is for 100 cycles.

Serial EEPROM manufactures – ST, Philips, Atmel, Dallas-Maxim usually have different interfaces like SPI, I2C, serial or parallel

Manufacturing Data – Date, serial number, test information, firmware, board ID 
System Parameters – interrupt address map, IP or port address, Laser or Motor bias current, analogue offsets
User Parameters – radio channel or telephone number presets
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MAX & MAX II Comparison
Parameter MAX MAX II

Process Technology 0.3-um EEPROM 0.18-um Flash
Logic Architecture Product Term Look-Up Table (LUT)
Density Range 32 to 512 Macrocells 128 to 2210 Macrocells

(240 to 2,210 LEs)
Routing Architecture Global Row & Column
On-Chip Flash Memory None 8 Kbits
Maximum User I/O 
Pins

212 272

Supply Voltage 5.0 V, 3.3 V, 2.5 V 3.3 V/2.5 V, 1.8 V
I/O Voltages 5.0 V, 3.3 V, 2.5 V, 1.8 V 3.3 V, 2.5 V, 1.8 V, 1.5 V
Global Clock Networks 2 per Device 4 per Device
Output Enables (OEs) 6 to 10 per Device 1 per I/O Pin
Schmitt Triggers None 1 per I/O Pin
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What is Nios II?
 Altera’s Second Generation Soft-Core 32 Bit RISC Microprocessor

− Developed Internally By Altera
− Harvard Architecture
− Royalty-Free

FPGA

- Nios II Plus All Peripherals Written In HDL
- Can Be Targeted For All Altera FPGAs
- Synthesis Using Quartus II Integrated Synthesis

Av
al

on
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w
itc

h 
Fa

br
ic UART

GPIO

Timer

SPI

SDRAM
Controller

On-Chip
ROM

On-Chip
RAM

Nios II
CPU
Debug C

ac
he

Presenter
Presentation Notes
Nios II is a soft-core 32 bit RISC microprocessor that has been developed internally by Altera.  It’s based on a Harvard architecture with a 32-bit instruction and data path, separate instruction and data cache, and 32 general purpose registers, and three formats of triadic instructions.  It’s closely related to the public domain Stanford MIPS.  It’s similar to Nios but is higher performance, has an improved software development flow using the new Nios II IDE (which will be discussed as the presentation rolls along), and it now comes in three “flavors” which I will also discuss shortly. 

So what does it mean to say “soft-core” processor? 
It means that the processor, itself, if synthesized out of the logic elements of the particular device architecture that you are programming your part into.  In other words, the up is buried in the FPGA. 

This differs significantly from the common notion of what embedded processors are (ie. off the shelf discrete up’s that you can purchase and implement on a board), and it also differs significantly from a custom ASSP-type hard-core processor which is really a dedicated region of silicon where a processor core gets  pre-fabricated into the FPGA.  That region of the FPGA will always have the same function on your chip (ie. to be a microprocessor). 
The soft-core processor is constructed from general purpose gates, routing resources, etc. and offers tremendous flexibility advantages over the more conventional microprocessors, and we’ll get into why this is so as we move along. 

NB
Configurable Soft-Core Processor
World’s most versatile processor
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Nios II Processor Architecture
Classic Pipelined RISC Machine

− 32 General Purpose Registers
− 3 Instruction Formats 
− 32-Bit Instructions
− 32-Bit Data Path
− Flat Register File
− Separate Instruction and Data Cache (configurable sizes)
− Tightly-Coupled Memory Options
− Branch Prediction
− 32 Prioritized Interrupts
− On-Chip Hardware (Multiply, Shift, Rotate)
− Custom Instructions
− JTAG-Based Hardware Debug Unit

Presenter
Presentation Notes
<go through these comparisons for those that are familiar with Nios>
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Problem:  Reduce Cost, Complexity & 
Power

Flash

SDRAM

CPU

DSP

I/O

I/O

I/O FPGA

I/O I/O I/O

CPU DSP

Solution: Replace External Devices 
with Programmable Logic

FPGA

Presenter
Presentation Notes
Why is Nios so attractive?
Traditional approach – board level integration using discrete components
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Problem:  Reduce Cost, Complexity & 
Power

Flash

SDRAM

Solution: Replace External Devices 
with Programmable Logic

CPU is a Critical Control Function 
Required for System-Level Integration

System On A Programmable Chip (SOPC)

FPGA

Presenter
Presentation Notes
Why is Nios so attractive?
Traditional approach – board level integration using discrete components
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Licensing
 Nios II Delivered As Encrypted Megacore

− Licensed Via Feature Line In Existing Quartus II License File
− Consistent With General Altera Megacore Delivery Mechanism
− Enables Detection Of Nios II In Customer Designs (Talkback)

 No Nios II Feature Line (OpenCore Plus Mode)
− System Runs If Tethered To Host PC
− System Times Out If Disconnected from PC After ~ 1 hr

 Nios II Feature Line (Active Subscriber)
− Subscription and New Dev Kit Customers Obtain Licenses From 

www.altera.com
− Nios II CPU RTL Remains Encrypted

 Nios II Source License
− Available Upon Request On Case-By-Case Basis
− Included With Purchase Of Nios II ASIC License

Presenter
Presentation Notes
Nios II ships as an encrypted megacore, just like all other megacore IP from Altera.  There are three ways to use Nios II depending on the license: 
1.  No Nios II License File Feature Line . Nios II will generate FPGA configuration files that operate in OpenCore Plus mode.  In other words, as long as the customer.s board is tethered to the host PC (Quartus II), the Nios II system will run.  After they disconnect from the host PC (~ 1 hour), the design will timeout and stop running.  OpenCore Plus lets customers design, simulate and run Nios II based designs without having to purchase a development kit.  
2.  Nios II License File Feature Line (Active Subscriber) . Customers who purchase a Nios II development kit, or who receive a Nios II upgrade (i.e. all active Nios subscribers as of May, 2004), must request a Nios II license from the Altera web site which will add a FlexLM feature line to their Altera license file which will enable them to generation configuration files that have no time limit.  The RTL generated for the Nios II CPU core is encrypted.  
Nios II Source License . Customers who purchase a Nios II ASIC license will get an additional feature line to enable plain text RTL generation of the Nios II processor core.  If you have a customer who absolutely insists on getting full source code, it can be made available on a case-by-case basis.

--

Note:  Nios II IDE does not require a license.  Thus, you do not require a license to develop code for use with Nios II.  Also, you can sort out a license server arrangement for Quartus II and Nios II.

http://www.altera.com/
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Quartus II Basic Training

Quartus II Development System 
Feature Overview
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Software & Development Tools
Quartus II

− All Stratix, Cyclone & Hardcopy Devices
− APEX II, APEX 20K/E/C, Excalibur, & 

Mercury Devices
− FLEX 10K/A/E, ACEX 1K, FLEX 6000 

Devices
− MAX II,  MAX 7000S/AE/B, MAX 3000A 

Devices
Quartus II Web Edition

− Free Version 
− Not All Features & Devices Included

 See www.altera.com for Feature 
Comparison

MAX+PLUS® II
− All FLEX, ACEX, & MAX Devices

http://www.altera.com/
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Quartus II Development System
Fully-Integrated Design Tool

− Multiple Design Entry Methods
− Logic Synthesis
− Place & Route
− Simulation
− Timing & Power Analysis
− Device Programming
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Typical PLD Design Flow

Synthesis
- Translate Design into Device Specific Primitives
- Optimization to Meet Required Area & Performance Constraints
- Precision Synthesis, Synplify/Synplify Pro, Design Compiler FPGA, 

Quartus II

Design Specification

Place & Route
- Map Primitives to Specific Locations inside
Target Technology with Reference to Area &
Performance Constraints

- Specify Routing Resources to Be Used

Design Entry/RTL Coding
- Behavioral or Structural Description of Design

RTL Simulation
- Functional Simulation (Modelsim®, Quartus II)
- Verify Logic Model & Data Flow 

(No Timing Delays)

LE M512

M4K I/O
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Typical PLD Design Flow
Timing Analysis
- Verify Performance Specifications Were Met
- Static Timing Analysis

Gate Level Simulation
- Timing Simulation
- Verify Design Will Work in Target Technology

PC Board Simulation & Test
- Simulate Board Design
- Program & Test Device on Board
- Use SignalTap II for Debugging

tclk
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Design Entry Methods
Quartus II

− Text Editor
 AHDL
 VHDL
 Verilog

− Schematic Editor
 Block Diagram File
 Graphic Design File

− Memory Editor
 HEX
 MIF

 3rd-Party EDA Tools
− EDIF
− HDL
− VQM

Mixing & Matching Design Files Allowed

Top-level design files can 
be schematic, HDL or 3rd-
Party Netlist File

Block
File

Symbol
File

Text
File

Text
File

Text
File

Imported from 3rd-Party 
EDA toolsGenerated within Quartus II

Text
File

Text
File

.v, vlg,
.vhd, .vhdl, 

vqm

.edf
.edif

.v.vhd.tdf.bsf.bdf
.gdf

Top-
Level 
File
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Quartus II Basic Training 
Quartus II Quick Start

LAB1
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Objectives 
Create a project using the New Project 

Wizard
Name the project
Add design files
Pick a device
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Step 1 (Setup Project for QII5_1) 
Under File, Select New Project Wizard…. 
A new window appears.  If an Introduction 
screen appears, click Next.
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Step 2 (Setup Project for QII5_1)
Page 1 of the wizard should be completed with the following 

working directory for this project <lab_install_directory> \Dsp_7_segment\

name of project Dsp_7_segment

top-level design entity Dsp_7_segment

Copy “state_machine.v” and past in
Dsp_7_segment

Click Next to advance to the 
Project Wizard: Add Files [page 2 of 5].
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Step 3 (Setup Project for QII5_1)
Using the browse button, select state_machine.v
Add to the project.  Click Next.
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Step 4 (Setup Project for QII5_1)
On page 3, select Stratix as the Family.  Also, in the Filters section,
set Package to FBFA, Pin count to 780, and Speed grade to 5. 
Select the EP1S25F780C5 device from 
the Available devices: window. Click Next.
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Step 5 (Setup Project for QII5_1)
On page 4 , you can specify any third party EDA tools you may be using 
along with Quartus II.  Since these exercises will be done entirely within 
Quartus II, click Next.
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Step 6 (Setup Project for QII5_1)
The summary screen appears as shown. Click Finish. 
The project is now created.
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Quartus II Basic Training 
Quartus II Quick Start

LAB2
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Objectives 
Create a counter using the MegaWizard 

Plug-in Manager
Build a design using the schematic editor
Analyze and elaborate the design to check 

for errors
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Step 1 Create schematic file
Select File ⇒ New and select Block Diagram/Schematic File.  Click OK.
Select File ⇒ Save As and save the file as

<lab_install_directory> \Dsp_7_segment\ Dsp_7_segment.bdf
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Step 2 Build an 23 bits counter using the MegaWizard Plug-in Manager

1.Choose Tools ⇒ MegaWizard Plug-In Manager. In the window that appears, 
select Create a new custom megafunction variation.  Click on Next.

2.On page 2a of the MegaWizard expand the arithmetic folder and select
LPM_COUNTER.

3.Choose Verilog HDL output For the name of the output file, type timer_1s. 
Click on Next
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Step 3
1. Set the output bus to 27 bits. For the remaining settings in this window, 

use the defaults that appear ..  Select next
2. .Turn on “Modulus , with a count modulus of “and key in 79999999
3. Select finish
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Step 4
In the Graphic Editor, double-click in the screen so that the Symbol Window
appears.  Inside the symbol window, click on      to expand the symbols defined 
in the Project folder.  Double-click on timer_1s. Click the 
left mouse button to put down the symbol inside the schematic file.. The symbol
for “timer_1s” now appears in the schematic.
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Step 5
1. From the File menu, open the file state_machine.v
2. From the File menu, go the Create/Update menu option and select

Create Symbol Files for Current File.  Click Yes to save changes
to Dsp_7_segment.bdf.

3. Once Quartus II is finished creating the symbol, click OK.  Close the
state_machine.v file 

4. In the Graphic Editor, double-click in the screen so that the Symbol
Window appears again.  Double-click on state_machine in the 
Project folder. Click OK... The symbol for state_machine now 
appears in the schematic.
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Step 6 Add Pins to the Design 
Input Output

sys_clk 7_out[6..0]

reset Dig1

For each of the pins listed in left Table , you must insert
a pin and change its name 

1. To place pins in the schematic file, go to Edit ⇒ Insert ⇒ Symbol OR
double-click in any empty location of the Graphic Editor. 

2. Browse to libraries ⇒ primitives ⇒ pin folder.  Double-click on input
or output Hint:  To insert multiple pins select Repeat Insert Mode.

3. To rename the pins double-click on the pin name after it has been
inserted.

4. Type the name in the Pin name(s) field and Click OK
.
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Step 7 Connect the Pins and Blocks in the Schematic

1. In the left hand tool bar click on       button to draw a wire and       button to draw a bus.  
Another way to draw wires and busses is to place the cursor next to the port of any 
symbol.  When you do this, the wire or bus tool will automatically appear.

2. Connect all of the pins and blocks as shown in the figure below
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Step 8 Save and check the schematic 
1. Click on the Save button in the toolbar      to save the schematic. 
2. From the Project menu, select Add/Remove Files in Project.  

Click on the browse button to make sure the Dsp_7_segment.bdf, 
timer_1s and state_machine are added  to the project.

3. From the Processing menu, select Start ⇒ Start Analysis & Elaboration. 

Analysis and elaboration checks that all the design files are present and
connections have been made correctly.

4. Click OK when analysis and elaboration is completed
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Objectives 
Pin assignment
Perform full compilation Build a design 

using the schematic editor
How to Download programming file 
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Step 1
1. Choose Assignments ⇒ Assignment editor.
2. From the View menu, select Show All Know Pin Names.
3. Please click Pin in Category
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Step 2
1. Pls install DSP Development Kit  Stratix edtion CD
2. Open ds_stratix_dsp_bd.pdf from C:\megacore\stratix_dsp_kit-v1.1.0\Doc
3. Check clk , pushbotton and seven segment display pin location from 

ds_stratix_dsp_bd.pdf 
4. Key your pin number in location
5. Click on the Save button in the toolbar 
6. From Assignments, select Device. Click Device & Pin options. Click

Unused pins .Select As input tri-stated from Reserve all unused pins
7. From the Processing menu, select Start Compilation 
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Step 3
1. From the Tools menu, select programmer
2. Click on Add File. Select Dsp_7_segment.sof.
3. Check Hardware Setup. Select your download cable on 

Currently selected hardware(ByteBlasterII)
4. Select JTAG from Mode
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Step 4
1. Turn on Program/configure. Or see figure below
2. Click Start
3. See 7-segment status
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